مناسب ترین نسخه PHP برای وردپرس 5

بهترین نسخه PHP مناسب وردپرس 5 چیست؟
در حال حاضر از بین ورژن های مختلف php مانند 7.0 و 7.1 و 7.2 و 7.3 ، ما ورژن php7.2 را به شما پیشنهاد می‌کنیم. اما چرا؟

ورژن های 7.0 و 7.1 کمی قدیمی شده‌اند و جدیدترین نسخه‌ها 7.2 و 7.3 هستند. اما نسخه 7.3 php چون بیش‌ازحد جدید است افزونه‌ها و قالب‌های وردپرس با آن کامل سازگار نیستند و در برخی موارد خطا تولید می‌کنند. در کارگاه چهارم طراحی سایت ما این مشکل به وجود آمد که برخی از دوستان از آخرین نسخه php استفاده کردند و بعد از فعال‌سازی قالب پیام خطا دریافت می‌کردند.

چرا عمر PHP5.6 تمام شد و باید کوچ کرد
دلایل زیادی وجود دارد که باید این کار را انجام بدهیم مانند:

  • سرعت کمتر
  • هشدار وردپرس راجع به این نسخه در پنل مدیریتی وردپرس
  • پایان پشتیبانی
  • امنیت کمتر
  • نداشتن سازگاری با نسخه های جدید افزونه ها و قالب های وردپرس

مهم‌ترین دلیل برای کوچ به نسخه های بالاتر ،سازگاری با قالب‌ها و افزونه‌های جدید است که دیگر نسخه‌های قدیمی php را پشتیبانی نمی‌کنند
مزیت های نسخه php7.2
این نسخه از php جزو پایدارترین نسخه ها در حال حاظر است و مزیت های آن عبارتند از:

  • سرعت بیشتر
  • امنیت بیشتر
  • موجود بودن پشتیبانی
  • سازگاری بالا با قالب ها و افزونه های وردپرس

ارتقاء نسخه PHP سایت در cpanel
قبل از انجام این کار در صورتی که بک آپ کامل از سایت خودتان تهیه نکردید حتما تهیه کنید. در صورتی که شما از کنترل پنل cpanel استفاده می کنید باید مانند عکس زیر به قسمت multi php manager بروید.


در صفحه بعدی مانند عکس زیر، نام دامنه خود را انتخاب و سپس نسخه php7.2 را انتخاب کنید. و روی گزینه apply کلیک کنید.

تمام

1 Likes